升级 Centos 7 内核,使内核支持BBR

关于内核版本的定义:

版本性质:主分支ml(mainline),稳定版(stable),长期维护版lt(longterm)

版本命名格式为 “A.B.C”:

数字 A 是内核版本号:版本号只有在代码和内核的概念有重大改变的时候才会改变,历史上有两次变化:
数字 B 是内核主版本号:主版本号根据传统的奇-偶系统版本编号来分配:奇数为开发版,偶数为稳定版
数字 C 是内核次版本号:次版本号是无论在内核增加安全补丁、修复bug、实现新的特性或者驱动时都会改变

开启Google BBR需要 4.9 以上的内核才能支持,而centos 7默认的内核为3.10。简单写了一下升级 CentOS 7 升级到最新内核教程。

1、查看当前系统内核版本

uname -r

3.10.0-514.el7.x86_64

2、升级内核 

升级内核需要先导入elrepo的key,然后安装elrepo的yum源:

rpm --import https://www.elrepo.org/RPM-GPG-KEY-elrepo.org
yum install -y https://www.elrepo.org/elrepo-release-7.0-4.el7.elrepo.noarch.rpm

如果要安装ml内核,使用如下命令:

yum --enablerepo=elrepo-kernel -y install kernel-ml-devel kernel-ml

如果要安装lt内核,使用如下命令:

yum --enablerepo=elrepo-kernel -y install kernel-lt-devel kernel-lt

3、设置为默认内核

grub2-set-default 0
grub2-mkconfig -o /boot/grub2/grub.cfg 

4、删除旧的内核

查看已安装的内核

rpm -qa | grep kernel

删除旧内核

yum remove 内核名称

5、安装新版本工具包(可选操作)

移除旧版本

yum remove kernel-tools-libs kernel-tools kernel-headers

安装新版本

如果安装ml版本执行:

yum --disablerepo=* --enablerepo=elrepo-kernel install kernel-ml-tools kernel-ml-headers -y

如果安装lt版本执行: 

yum --disablerepo=* --enablerepo=elrepo-kernel install kernel-lt-tools kernel-lt-headers -y

6、reboot重启机器,然后查看内核版本

uname -r

5.5.6-1.el7.elrepo.x86_64